Probleme mit dem Plugin Polylang

und deren Lösung

Kürzlich hatte ich ein Problem mit mit Mehrsprachigkeits-Plugin Polylang. Plötzlich funktionierte es nicht mehr richtig, und mir wurde die folgende Fehlermeldung angezeigt:

Polylang has been deactivated because you upgraded from a too old version.

Please upgrade first to 0.9.8 before ugrading to 1.4.5.

Ich hatte das Plugin jedoch nicht geupdgraded, und zudem ist die Veröffentlichung der genannten Version 0.9.8 schon eine ganze Weile her. Daher schien das Problem wo anders zu liegen.

Mehrsprachige Website mit WordPress

Die Übersicht

Multilingual Press Free

Multilingual Press Free

WordPress wurde ursprünglich als reines Blogging-System entwickelt, und unterstützt daher von Haus aus keine mehrsprachigen Inhalte.

Man könnte zwar trotzdem Beiträge und Seiten in verschiedenen Sprachen verfassen, allerdings bliebe dann das Design, die Menüs und alle Widgets in ein und der selben Sprache. Auch im Beitrags-Archiv würden die Beiträge aller Sprachen auf einem Haufen angezeigt werden, und nicht voneinander getrennt. Außerdem wäre es nicht ohne weiteres möglich, die verschiedenen Sprachen einer Seite oder eines Beitrags miteinander zu verknüpfen, und zwischen diesen z.B. mit einem Sprachschalter in der Sidebar zu wechseln.

Um dennoch eine wirklich mehrsprachige Website mit WordPress erstellen zu können, gibt es genau zwei Möglichkeiten: Entweder man verwendet die Multisite-Funktion von WordPress, womit man dann für jede Sprache eine eigene Website anlegt, oder man verwendet ein Plugin, dass WordPress um die Mehrsprachigkeit erweitert.

Blogroll · Kontakt · Impressum